Dire Wolf
Time Limit: 5000/5000 MS (Java/Others) Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 2877 Accepted Submission(s): 1712
php
Problem Description
Dire wolves, also known as Dark wolves, are extraordinarily large and powerful wolves. Many, if not all, Dire Wolves appear to originate from Draenor.
Dire wolves look like normal wolves, but these creatures are of nearly twice the size. These powerful beasts, 8 - 9 feet long and weighing 600 - 800 pounds, are the most well-known orc mounts. As tall as a man, these great wolves have long tusked jaws that look like they could snap an iron bar. They have burning red eyes. Dire wolves are mottled gray or black in color. Dire wolves thrive in the northern regions of Kalimdor and in Mulgore.
Dire wolves are efficient pack hunters that kill anything they catch. They prefer to attack in packs, surrounding and flanking a foe when they can.
— Wowpedia, Your wiki guide to the World of Warcra
Matt, an adventurer from the Eastern Kingdoms, meets a pack of dire wolves. There are N wolves standing in a row (numbered with 1 to N from left to right). Matt has to defeat all of them to survive.
Once Matt defeats a dire wolf, he will take some damage which is equal to the wolf’s current attack. As gregarious beasts, each dire wolf i can increase its adjacent wolves’ attack by b
i. Thus, each dire wolf i’s current attack consists of two parts, its basic attack ai and the extra attack provided by the current adjacent wolves. The increase of attack is temporary. Once a wolf is defeated, its adjacent wolves will no longer get extra attack from it. However, these two wolves (if exist) will become adjacent to each other now.
For example, suppose there are 3 dire wolves standing in a row, whose basic attacks ai are (3, 5, 7), respectively. The extra attacks b
i they can provide are (8, 2, 0). Thus, the current attacks of them are (5, 13, 9). If Matt defeats the second wolf first, he will get 13 points of damage and the alive wolves’ current attacks become (3, 15).
As an alert and resourceful adventurer, Matt can decide the order of the dire wolves he defeats. Therefore, he wants to know the least damage he has to take to defeat all the wolves.
Input
The first line contains only one integer T , which indicates the number of test cases. For each test case, the first line contains only one integer N (2 ≤ N ≤ 200).
The second line contains N integers a
i (0 ≤ a
i ≤ 100000), denoting the basic attack of each dire wolf.
The third line contains N integers b
i (0 ≤ b
i ≤ 50000), denoting the extra attack each dire wolf can provide.
Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), y is the least damage Matt needs to take.
Sample Input
2
3
3 5 7
8 2 0
10 1 3 5 7 9 2 4 6 8 10
9 4 1 2 1 2 1 4 5 1
Sample Output
Case #1: 17
Case #2: 74
Hint
In the first sample, Matt defeats the dire wolves from left to right. He takes 5 + 5 + 7 = 17 points of damage which is the least damage he has to take.
Source
题意:
有n只狼排成一排,每只狼有一个初始的攻击力和一块魔法石,魔法石可以做用在相邻的两只狼身上使其攻击力暂时增长(非永久)必定的数值,如今要杀狼,花费是每只狼的攻击力,求把狼杀死的最小花费
输入n
输入n只狼初始攻击力
输入n只狼的魔法石的魔力
代码:
//初始攻击力能够先不用管直接加到结果里,而后就能够区间dp了,dp[i][j][0]表示i~j区间中只剩下一个魔法石时的最小花费
//f[i][j][1]表示剩下哪一个魔法石。由于最后会剩下一个不用的魔法石。
#include<bits/stdc++.h>
using namespace std;
const int INF=0x3f3f3f3f;
int t,n,b[209],f[209][209][2];
int main()
{
scanf("%d",&t);
for(int cas=1;cas<=t;cas++){
int sum=0,x;
scanf("%d",&n);
for(int i=1;i<=n;i++){
scanf("%d",&x);
sum+=x;
}
for(int i=1;i<=n;i++) scanf("%d",&b[i]);
for(int i=1;i<=n;i++){
f[i][i][0]=0;
f[i][i][1]=i;
}
for(int i=2;i<=n;i++){
for(int j=i-1;j>=1;j--){
f[j][i][0]=INF;
for(int k=j;k<i;k++){
int tmp1=b[f[k+1][i][1]];
if(j>1) tmp1+=b[j-1];
int tmp2=b[f[j][k][1]];
if(i<n) tmp2+=b[i+1];
if(f[j][k][0]+f[k+1][i][0] + min(tmp1,tmp2) < f[j][i][0]){
f[j][i][0] = f[j][k][0]+f[k+1][i][0] + min(tmp1,tmp2);
if(tmp2<tmp1) f[j][i][1]=f[j][k][1];
else f[j][i][1]=f[k+1][i][1];
}
}
//cout<<j<<" "<<i<<" \\ "<<f[j][i][0]<<endl;
}
}
printf("Case #%d: %d\n",cas,f[1][n][0]+sum);
}
return 0;
}