HDU 5584 LCM Walk 数学

LCM Walk

Time Limit: 20 Secphp

Memory Limit: 256 MBios

题目链接

http://acm.hdu.edu.cn/showproblem.php?pid=5584ide

Description

A frog has just learned some number theory, and can't wait to show his ability to his girlfriend.spa

Now the frog is sitting on a grid map of infinite rows and columns. Rows are numbered 1,2,⋯ from the bottom, so are the columns. At first the frog is sitting at grid (sx,sy), and begins his journey.code

To show his girlfriend his talents in math, he uses a special way of jump. If currently the frog is at the grid (x,y), first of all, he will find the minimum z that can be divided by both x and y, and jump exactly z steps to the up, or to the right. So the next possible grid will be (x+z,y), or (x,y+z).blog

After a finite number of steps (perhaps zero), he finally finishes at grid (ex,ey). However, he is too tired and he forgets the position of his starting grid!ip

It will be too stupid to check each grid one by one, so please tell the frog the number of possible starting grids that can reach (ex,ey)!ci

Inputget

First line contains an integer T, which indicates the number of test cases.qt

Every test case contains two integers ex and ey, which is the destination grid.

⋅ 1≤T≤1000.
⋅ 1≤ex,ey≤109.

Output

For every test case, you should output "Case #x: y", where x indicates the case number and counts from 1 and y is the number of possible starting grids.

Sample Input

3
6 10
6 8
2 8

Sample Output

Case #1: 1
Case #2: 2
Case #3: 3

HINT

 

题意

给你(x,y) 而后能够走到(x+lcm(x,y),y)或者走到(x,y+lcm(x,y))

而后如今给你一个位置,问你起点有多少种。

题解:

假设x = pt,y =qt 

因此(pt,qt),那么下一步就能够走到(pt(1+q),qt)或者走到(pt,(1+p)qt)

那么很显然咱们走到了(x,y) 那么上一步就是 (x/(y+1),y)和(x,y/(x+1))

代码:

#include<iostream>
#include<stdio.h>
using namespace std;

int gcd(int a,int b)
{
    return b==0?a:gcd(b,a%b);
}
int ans = 0;
void solve(int x,int y)
{
    ans++;
    if(x<y)swap(x,y);
    if(x%(y+1)==0)solve(x/(y+1),y);
}
int main()
{
    int t;
    scanf("%d",&t);
    for(int cas=1;cas<=t;cas++)
    {
        ans = 0;
        int x,y;
        scanf("%d%d",&x,&y);
        int p = gcd(x,y);
        x = x/p,y = y/p;
        solve(x,y);
        printf("Case #%d: %d\n",cas,ans);
    }
}
相关文章
相关标签/搜索