欧拉函数

欧拉函数:web

大意:表示的是一个数有几个与它互质的数,好比8的欧拉数为4(1 3 5 7);函数

例题:spa

 

Descriptioncode

A lattice point (x, y) in the first quadrant (x and y are integers greater than or equal to 0), other than the origin, is visible from the origin if the line from (0, 0) to (x, y) does not pass through any other lattice point. For example, the point (4, 2) is not visible since the line from the origin passes through (2, 1). The figure below shows the points (x, y) with 0 ≤ x, y ≤ 5 with lines from the origin to the visible points.orm

Write a program which, given a value for the size, N, computes the number of visible points (x, y) with 0 ≤ x, yN.ip

Inputinput

The first line of input contains a single integer C (1 ≤ C ≤ 1000) which is the number of datasets that follow.it

Each dataset consists of a single line of input containing a single integer N (1 ≤ N ≤ 1000), which is the size.io

Outputclass

For each dataset, there is to be one line of output consisting of: the dataset number starting at 1, a single space, the size, a single space and the number of visible points for that size.

Sample Input

4 2 4 5 231

Sample Output

1 2 5 2 4 13 3 5 21 4 231 32549

 

题目大意:一个(n+1)*(n+1)的点阵,问多少点能被点(0,0)看到。若是(0,0)到(i,j)的连线被点挡住就算看不到。

先画一条(0, 0)到(n, n)的线,把图分红两部分,两部分是对称的,只需算一部分就好。取右下半,这一半里的点(x, y)知足x >= y能够经过欧拉函数计算第k列有多少点可以连到(0, 0)若x与k的最大公约数d > 1,则(0, 0)与(x, k)点的脸先一定会经过(x/d, k/d),就被挡住了因此能连的线的数目就是比k小的、和k互质的数的个数,而后就是欧拉函数。因为是对称的,因此只需算一半的数量就够了。第k列上的一个点的纵坐标为d,若gcd(k,d) != 1,则远带你与该点的连线必须经过(k/gcd,d/gcd),确定被挡住了。

由此咱们能够获得递推公式 res1[i] = res1[i-1] + 2*phi[i];其中phi[i]是第i列上能看到的点的个数,

由此便转化为了欧拉函数:

code:

 #include<stdio.h>
#define MMAX 1000006
int e[MMAX];
void f()//欧拉函数
{
    int i,j;
    for(i=1; i<MMAX; i++)  
          e[i]=i;
    for(j=2; j<MMAX; j++)
        if(e[j]==j)
            for(i=j; i<MMAX; i+=j)
                e[i]=e[i]/j*(j-1);
}
int main()
{
    int n,i,t,case1=1;
    f();
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        long long sum=0;
        for(i=2; i<=n; i++)//n-1列加一块儿
            sum+=e[i];
        printf("%d %d %lld\n",case1++,n,sum*2+3);
    }
    return 0;
}
相关文章
相关标签/搜索