PAT 甲级 1068 Find More Coins (30 分) (dp,01背包问题记录最佳选择方案)***

1068 Find More Coins (30 分)
 

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she must pay the exact amount. Since she has as many as 1 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.html

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤, the total number of coins) and M (≤, the amount of money Eva has to pay). The second line contains Nface values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.ios

Output Specification:

For each test case, print in one line the face values V1​​V2​​Vk​​ such that V1​​+V2​​++Vk​​=M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output "No Solution" instead.数组

Note: sequence {A[1], A[2], ...} is said to be "smaller" than sequence {B[1], B[2], ...} if there exists k1 such that A[i]=B[i] for all i<k, and A[k] < B[k].flex

Sample Input 1:

8 9
5 9 8 7 2 3 4 1

Sample Output 1:

1 3 5

Sample Input 2:

4 8 7 2 4 3 

Sample Output 2:

No Solution

 

题意:ui

用n个硬币买价值为m的东西,输出使用方案,使得正好几个硬币加起来价值为m。从小到大排列,输出最小的那个排列方案spa

题解:code

  这是一道01背包问题,解题时注意题意的转化:htm

  • 能够将每一个coin都当作value和weight都相同的物品
  • 要求所付的钱刚恰好,至关于要求背包必须恰好塞满,且价值最大。(限制背包体积至关于限制coin的总和不能超过所要付的钱,在此条件下求coin组合的最大值,若是这个最大值恰好等于要付的钱,则有解,此时背包也恰好处于塞满状态,不然无解)
  • 最后要求从小到大输出coin的组合,且有多解时输出最小的组合。这是此题的难点所在,咱们应该将coin从大到小排序,在放进背包时也从大到小逐个检查物品,更新背包价值的条件是在加入一个新的物品后,价值>=原价值,注意此时等号的意义,因为物品是从大到小排序的,若是一个新的物品的加入能够保证价值和原来相同,则此时必定是发现了更小的组合。
  做者:cheerss
  连接:https://www.jianshu.com/p/20dac38241a5
  来源:简书
  著做权归做者全部。商业转载请联系做者得到受权,非商业转载请注明出处。
 
  想到了背包和dp,可是一时间忘记怎么记录路径了。。。只好看别人的了,之后要回来回顾一下。。。。用数组标记的方式记录选择路径。
  问题的难点在于输出最小序列,一开始从小到大排了,原来应该从大到小排。由于先输出的是最后选的,越到后面选择越是小的。
 

AC代码:blog

#include<iostream>
#include<queue>
#include<algorithm>
using namespace std;
int dp[101];//bags[i]面值不大于i的最大的面值和
bool choice[10001][101];
int cmp(int a, int b){return a > b;}
int main(){
    int w[10001];
    int n,m;
    cin>>n>>m;
    for(int i=1;i<=n;i++){
        cin>>w[i];
    }
    sort(w+1,w+1+n,cmp);
    for(int i=1;i<=n;i++){
        for(int j=m;j>=w[i];j--){ //之因此要反着来,和背包问题的更新规则有关
            if(dp[j-w[i]]+w[i]>=dp[j]){//等号必须取到,不然输出的解是最大的sequence
                choice[i][j]=true;//跟踪哪一个物品被选择了
                dp[j]=dp[j-w[i]]+w[i];
            }
        }
    }
    if(dp[m] != m) printf("No Solution");
    else{  //下面是输出最优组合的过程,其实和背包问题的更新规则有关,就是沿着选出解的路径,反着走回去,就找到了全部被选择的数字。
        int i=n,j=m;
        while(1){
            if(choice[i][j]==true){
                cout<<w[i];
                j-=w[i];
                if(j!=0) cout<<" ";
            }
            i--;
            if(j==0||i==0) break;
        }
    }
    return 0;
}
相关文章
相关标签/搜索