PAT 甲级 1048.Find Coins C++/Java

题目来源java

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.ios

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤105, the total number of coins) and M (≤103, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.c++

Output Specification:

For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1+V2=M and V1≤V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output No Solution instead.数组

Sample Input 1:

8 15
1 2 8 7 2 4 11 15

Sample Output 1:

4 11

Sample Input 2:

7 14
1 8 7 2 4 11 15

Sample Output 2:

No Solution

题意:

给出两个数N和Mui

接下来输入N个数字spa

是否存在两个数 a 和 b,知足 a + b = M指针

  • 存在:依次输出a和b(知足a ≤ b)
  • 不存在:输出 No Solution

分析:

1. 双指针

先对数组排序,初始化两个指针left和right,分别指向数组两端code

  • left + right < m:left++
  • left + right > m:right--
  • left + right == m:输出 left right
  • 当left <= right 退出循环

2. 哈希表

出现过的数字存入表中,记录出现过的次数排序

在hash中找到一对数字 hash[i]hash[m - i],它们的和为 mci

注意:

  • 当 i = m - i,必须保证数字 i 的个数大于等于2,不然是不能够的
    • 好比须要14,有两个7,知足 7 + 7 = 14

c++实现:

1. 双指针

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;

int main() {
    int n;  // the total number of coins
    int m;  // the amount of money Eva has to pay
    cin >> n >> m;
    vector<int> arr(n);
    for (int i = 0; i < n; ++i) {
        cin >> arr[i];
    }
    sort(arr.begin(), arr.end());
    int left = 0;
    int right = n - 1;
    while (left != right) {
        if (arr[left] + arr[right] > m) {
            right--;
        }
        else if (arr[left] + arr[right] < m) {
            left++;
        }
        else {
            cout << arr[left] << ' ' << arr[right];
            return 0;
        }
    }
    cout << "No Solution";
    return 0;
}

2. 哈希表

#include <iostream>
using namespace std;

int arr[1001] = { 0 };
int main() {
    int n;  // the total number of coins
    int m;  // the amount of money Eva has to pay
    cin >> n >> m;
    int temp;
    for (int i = 0; i < n; ++i) {
        cin >> temp;
        arr[temp]++;
    }
    for (int i = 0; i < 1001; ++i) {
        if (arr[i] && arr[m - i]) {
            if (i == m - i && arr[i] <= 1) {
                continue;
            }
            cout << i << ' ' << m - i;
            return 0;
        }
    }
    cout << "No Solution";
    return 0;
}

Java实现:

相关文章
相关标签/搜索