Channel Allocation

Channel Allocation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 13231 Accepted: 6774ios

Description
When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not interfere with one another. This condition is satisfied if adjacent repeaters use different channels.markdown

Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of channels required.ui

Input
The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet starting with A. For example, ten repeaters would have the names A,B,C,…,I and J. A network with zero repeaters indicates the end of input.this

Following the number of repeaters is a list of adjacency relationships. Each line has the form:spa

A:BCDHcode

which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line has the formorm

A:ip

The repeaters are listed in alphabetical order.ci

Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross.input

Output
For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels is in the singular form when only one channel is required.

Sample Input

2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0

Sample Output

1 channel needed.
3 channels needed.
4 channels needed.

Source
Southern African 2001
看的Discuss说要用四色定理,不懂,因此就是纯粹的暴力,对于每一个节点记录它所连得节点,赋给这个节点和它相连的节点没有的颜色而且是最小的

#include <map>
#include <cmath>
#include <queue>
#include <stack>
#include <string>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
using namespace std;
const int INF =0x3f3f3f3f;
const int Max =120;
typedef pair <int ,int >p;
bool Map[30][30];
int colour[30];
bool vis[30];
int n,m;
int main()
{
    char s,c;
    char str[30];
    int MM;
    while(scanf("%d",&n)&&n)
    {
        memset(Map,false,sizeof(Map));
        for(int i=0;i<n;i++)
        {
            scanf("%c%c%s",&s,&c,str);
            for(int j=0;str[j];j++)
            {
                Map[i][str[j]-'A']=true;
            }
        }
        memset(colour,-1,sizeof(colour));
        MM=-1;
        for(int i=0;i<n;i++)
        {
            colour[i]=n+1;
            memset(vis,false,sizeof(vis));
            for(int j=0;j<n;j++)
            {
                if(Map[i][j]&&colour[j]!=-1)
                {
                    vis[colour[j]]=true;
                }
            }
            for(int j=1;j<=n;j++)
            {
                if(!vis[j])
                {
                    colour[i]=j;
                    break;
                }
            }
            if(MM<colour[i])
            {
                MM=colour[i];
            }
        }
        if(MM==1)
        {
            printf("1 channel needed.\n");
        }
        else
        {
            cout<<MM<<" channels needed."<<endl;
        }
    }
    return 0;
}