网络流之最大流Dinic --- poj 1459

题目连接node

 

Descriptionios

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= p max(u) of power, may consume an amount 0 <= c(u) <= min(s(u),c max(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= l max(u,v) of power delivered by u to v. Let Con=Σ uc(u) be the power consumed in the net. The problem is to compute the maximum value of Con.
An example is in figure 1. The label x/y of power station u shows that p(u)=x and p max(u)=y. The label x/y of consumer u shows that c(u)=x and c max(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and l max(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6.

Input算法

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of l max(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of p max(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of c max(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.

Outputapp

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.

Sample Inputide

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
         (3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
         (0)5 (1)2 (3)2 (4)1 (5)4

Sample Output优化

15
6
题意:由n个点构成的图,其中np个点为发电站最大发电量为zi,nc个点为用户最大消耗电量为zj,剩余点为中转点不产电也不消耗电,求此电网最大消耗电量?
 
思路:可将np个发电站看作源点,nc个用户点看作汇点,为了构成单源单汇点,增长一个源点0连向np个发电站,其边权为发电站的最大发电量;增长一个汇点n+1,由全部的用户连向汇点n+1,其边权为用户的最大消耗电量。此时,就变成了单纯的最大流问题。
 
注:第一次写Dinic最大流代码,简单介绍一下Dinic算法:
  EK(EdmondsKarp)最大流的思想为,每次采用bfs搜索找到一条增广路(设流量为flow),改变这条路径上的全部的边权值都减小flow,同时这条路径上的全部反向边权值增长flow,重复直至找不到增广路为止。
  Dinic算法很明显是EK的一个优化算法,其先采用 bfs 将图按深度分层,而后 dfs 找到全部的增广路并一样改变全部的边权值以及反向边的权值,很明显这样dfs贪心的找到全部的增广路并非最优解,故循环再用bfs从新分层,dfs找增广路,直到bfs分层没有路径能走到汇点,此时便是最大流量了。
 
最大流Dinic代码以下:
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <queue>
using namespace std;
const int N = 105;
const int MAXN = 1e9 + 7;

struct Edge {
    int to;
    int value;
    int next;
}e[2*N*N];
int head[N], cnt;
int deep[N];
int n, np, nc, m;

void insert(int u, int v, int value) {
    e[++cnt].to = v;
    e[cnt].value = value;
    e[cnt].next = head[u];
    head[u] = cnt;
}

void init() {
    memset(head, -1, sizeof(head));
    cnt = -1;
}

bool BFS() {
    memset(deep,-1,sizeof(deep));
    queue<int> Q;
    deep[0] = 0;
    Q.push(0);
    while (!Q.empty()) {
        int u = Q.front();
        Q.pop();
        for (int edge = head[u]; edge != -1; edge = e[edge].next) {
            int v = e[edge].to;
            if (deep[v] == -1 && e[edge].value > 0) {
                deep[v] = deep[u] + 1;
                Q.push(v);
            }
        }
    }
    if (deep[n + 1] == -1) return false;
    return true;
}

int DFS(int u,int flow_pre) {
    if (u == n + 1) return flow_pre;
    int flow = 0;
    for (int edge = head[u]; edge != -1; edge = e[edge].next) {
        int v = e[edge].to;
        if (deep[v] != deep[u]+1 || e[edge].value==0) continue;
        int _flow= DFS(v, min(flow_pre, e[edge].value));
        flow_pre -= _flow;
        flow += _flow;
        e[edge].value -= _flow;
        e[edge ^ 1].value += _flow;
        if (flow_pre == 0) break;
    }
    if (flow == 0) deep[u] = -1;
    return flow;
}
int GetMaxFlow() {
    int ans = 0;
    while (BFS()) {
        ans += DFS(0,MAXN);
    }
    return ans;
}
int main()
{
    while (scanf("%d%d%d%d", &n, &np, &nc, &m) != EOF) {
        init();
        int u, v, z;
        for (int i = 0; i < m; i++) {
            scanf(" (%d,%d)%d", &u, &v, &z);
            insert(u+1, v+1, z);
            insert(v+1, u+1, 0);
        }
        for (int i = 0; i < np; i++) {
            scanf(" (%d)%d", &u, &z);
            insert(0, u+1, z);
            insert(u+1, 0, 0);
        }
        for (int i = 0; i < nc; i++) {
            scanf(" (%d)%d", &u, &z);
            insert(u + 1, n + 1, z);
            insert(n + 1, u + 1, 0);
        }
        printf("%d\n",GetMaxFlow());
    }
}
相关文章
相关标签/搜索