ACM Hopscotch(挑战程序设计竞赛)

Hopscotch

Time Limit: 1000ms
Memory Limit: 65536KB
This problem will be judged on  PKU. Original ID:  3050
64-bit integer IO format:  %lld      Java class name:  Main
Type:   
The cows play the child's game of hopscotch in a non-traditional way.  Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes.

They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit (potentially a digit already visited).

With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201).

Determine the count of the number of distinct integers that can be created in this manner.

Input

* Lines 1..5: The grid, five integers per line

Output

* Line 1: The number of distinct integers that can be constructed

Sample Input

1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 2 1
1 1 1 1 1

Sample Output

15

Source

#include <iostream>
#include <cstdio>
#include <set>

using namespace std;

#define MAX_N 5

int map[MAX_N][MAX_N];
set<int> table;
int dx[]={1,-1,0,0};
int dy[]={0,0,1,-1};

void DFS(int x,int y,int cur,int num)
{
	if(cur==5)
	{
		if(table.find(num)==table.end())
		{
			table.insert(num);
		}


		return;
	}

	for(int i=0;i<4;i++)
	{
		int nx=x+dx[i],ny=y+dy[i];

		if(nx>=0 && nx<5 && ny>=0 && ny<5)
		{
			DFS(nx,ny,cur+1,num*10+map[ny][nx]);
		}
	}
}

int main()
{
	for(int i=0;i<5;i++)
	for(int j=0;j<5;j++)
		scanf("%d",&map[i][j]);

	for(int i=0;i<5;i++)
	for(int j=0;j<5;j++)
	{
		DFS(j,i,0,map[i][j]);
	}

	printf("%d\n",table.size());


	return 0;
}