网络工程师交换试验手册之十五:EIGRP实验

实验目的:
掌握EIGRP协议的基本工做原理,熟悉EIGRP协议配置的基本步骤。
实验拓扑:


实验内容:
1.路由器的基本配置
R3的基本配置
interface Loopback0
ip address 1.1.1.1 255.255.255.0
interface Serial1
ip address 192.168.10.3 255.255.255.0
encapsulation frame-relay
frame-relay map ip 192.168.10.3 102 broadcast
frame-relay map ip 192.168.10.4 102 broadcast
frame-relay map ip 192.168.10.5 103 broadcast
no frame-relay inverse-arp
R4上的基本配置
interface Loopback0
ip address 2.2.2.2 255.255.255.0
!
interface Loopback1
ip address 2.2.3.2 255.255.255.0
interface Serial0
ip address 192.168.10.4 255.255.255.0
encapsulation frame-relay
frame-relay map ip 192.168.10.3 201 broadcast
frame-relay map ip 192.168.10.4 201 broadcast
frame-relay map ip 192.168.10.5 201 broadcast
no frame-relay inverse-arp
R5上的基本配置
interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
interface Serial0
ip address 192.168.10.5 255.255.255.0
encapsulation frame-relay
frame-relay map ip 192.168.10.3 301 broadcast
frame-relay map ip 192.168.10.4 301 broadcast
frame-relay map ip 192.168.10.5 301 broadcast
no frame-relay inverse-arp
!
2.配置EIGRP协议
在R2上配置EIGPR协议
R3(config)#router eigrp 100
R3(config-router)#net 1.1.1.0
R3(config-router)#net 192.168.10.0
在R4上配置EIGRP协议
R4(config)#router eigrp 100
R4(config-router)#net 2.2.2.0
R4(config-router)#net 2.2.3.0
R4(config-router)#net 192.168.10.0
在R5上配置EIGRP协议
R5(config)#router eigrp 100
R5(config-router)#net 192.168.10.0
R5(config-router)#net 3.3.3.0
3.查看EIGRP路由表
查看R3上的路由表
R3#show ip route
05:49:42: %SYS-5-CONFIG_I: Configured from console by console
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
Gateway of last resort is not set
     1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D       1.0.0.0/8 is a summary, 00:02:54, Null0
C       1.1.1.0/24 is directly connected, Loopback0
D    2.0.0.0/8 [90/2297856] via 192.168.10.4, 00:01:00, Serial1
D    3.0.0.0/8 [90/2297856] via 192.168.10.5, 00:00:08, Serial1
C    192.168.10.0/24 is directly connected, Serial1
查看R4上的路由表
R4#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
Gateway of last resort is not set
D    1.0.0.0/8 [90/2297856] via 192.168.10.3, 00:00:36, Serial0
     2.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
D       2.0.0.0/8 is a summary, 00:01:06, Null0
C       2.2.2.0/24 is directly connected, Loopback0
C       2.2.3.0/24 is directly connected, Loopback1
C    192.168.10.0/24 is directly connected, Serial0
05:49:15: %SYS-5-CONFIG_I: Configured from console by console
查看R5上的路由表
R5#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
Gateway of last resort is not set
06:12:22: %SYS-5-CONFIG_I: Configured from console by console
     3.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D       3.0.0.0/8 is a summary, 00:00:10, Null0
C       3.3.3.0/24 is directly connected, Loopback0
C    192.168.10.0/24 is directly connected, Serial0
4.为EIGRP配置被动接口
将R4上的S0口配置为被动接口
查看此时的各个路由器上的路由表
R3上
R3#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
Gateway of last resort is not set
     1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D       1.0.0.0/8 is a summary, 00:01:54, Null0
C       1.1.1.0/24 is directly connected, Loopback0
D    3.0.0.0/8 [90/2297856] via 192.168.10.5, 00:01:54, Serial1
C    192.168.10.0/24 is directly connected, Serial1
R4上
R4#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
Gateway of last resort is not set
     2.0.0.0/24 is subnetted, 2 subnets
C       2.2.2.0 is directly connected, Loopback0
C       2.2.3.0 is directly connected, Loopback1
C    192.168.10.0/24 is directly connected, Serial0
R5上:
R5#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
Gateway of last resort is not set
D    1.0.0.0/8 [90/2297856] via 192.168.10.3, 00:00:03, Serial0
     3.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D       3.0.0.0/8 is a summary, 00:00:03, Null0
C       3.3.3.0/24 is directly connected, Loopback0
C    192.168.10.0/24 is directly connected, Serial0
重点:有路由表可知EIGRP的被动接口即不能够发送路由信息,也不能够接受路由更新信息。
实验总结: 对于第一学期来说EIGRP是没有必要掌握的,由于它被放到了第二学期去讲授,EIGRP是路由选路协议中收敛最快的协议,可是它的惟一缺点就是它是cisco自己的协议,若是你要用这个协议,那么你全部的设备必须都是cisco的。