Area——Pick公式

符号含义:
edge:图形边上的点的数目 
inner:图形内部的点的数目 
S:图形面积
 
Pick公式: S = e d g e 2 + i n n e r 1 S=\frac{edge}{2}+inner-1
html

题目描述ios

Being well known for its highly innovative products, Merck would definitely be a good target for industrial espionage. To protect its brand-new research and development facility the company has installed the latest system of surveillance robots patrolling the area. These robots move along the walls of the facility and report suspicious observations to the central security office. The only flaw in the system a competitor抯 agent could find is the fact that the robots radio their movements unencrypted. Not being able to find out more, the agent wants to use that information to calculate the exact size of the area occupied by the new facility. It is public knowledge that all the corners of the building are situated on a rectangular grid and that only straight walls are used. Figure 1 shows the course of a robot around an example area.
在这里插入图片描述c++

Figure 1: Example area.
You are hired to write a program that calculates the area occupied by the new facility from the movements of a robot along its walls. You can assume that this area is a polygon with corners on a rectangular grid. However, your boss insists that you use a formula he is so proud to have found somewhere. The formula relates the number I of grid points inside the polygon, the number E of grid points on the edges, and the total area A of the polygon. Unfortunately, you have lost the sheet on which he had written down that simple formula for you, so your first task is to find the formula yourself.

Input
The first line contains the number of scenarios.
For each scenario, you are given the number m, 3 <= m < 100, of movements of the robot in the first line. The following m lines contain pairs of integers, separated by a single blank, satisfying .-100 <= dx, dy <= 100 and (dx, dy) != (0, 0). Such a pair means that the robot moves on to a grid point dx units to the right and dy units upwards on the grid (with respect to the current position). You can assume that the curve along which the robot moves is closed and that it does not intersect or even touch itself except for the start and end points. The robot moves anti-clockwise around the building, so the area to be calculated lies to the left of the curve. It is known in advance that the whole polygon would fit into a square on the grid with a side length of 100 units.
Output
The output for every scenario begins with a line containing 揝cenario #i:� where i is the number of the scenario starting at 1. Then print a single line containing I, E, and A, the area A rounded to one digit after the decimal point. Separate the three numbers by two single blanks. Terminate the output for the scenario with a blank line.
Sample Inputgit

2
4
1 0
0 1
-1 0
0 -1
7
5 0
1 3
-2 2
-1 0
0 -3
-3 1
0 -3

Sample Outputweb

Scenario #1:
0 4 1.0

Scenario #2:
12 16 19.0

题意
给定一个机器人行动的轨迹(每次给出的是机器人移动的轨迹 )好比说例2中的5,0就是至关于x正向走5步,y正向走0步后达到的位置。已知这个机器人所移动的路径是一个多边形,如今让你求多边形内部的点,以及这个多边形的面积。
题解
解决这个问题咱们要用到博文开头提到的公式以及这篇博文的内容。咱们先来看一下需求,题目要咱们求多边形内部和多边形的边上的点以及多边形的面积。app

  • 首先来解决简单的,咱们知道,一个四边形的面积等于组成这个四边形的向量的外积(二维平面图形。外积 = x1*y2 - x2*y1)。而一个多边形能够划分为多个三角形,三角形的面积是四边形的面积的一半。由此咱们能够得出该题要求的该多边形的面积 \rightarrow 向量的外积 ÷ \div 2。
  • 再来解决多边形边上面的点的数目,移步此博客
  • 最后咱们就只剩下多边形内部的点的数目了。这时咱们利用Pick公式: i n n e r = S + 1 e d g e 2 inner = S+1-\frac{edge}{2} ,这样咱们就把内部的点的数量求出来了。至此,题目的整个需求咱们就完成了。
     

c++ AC 代码ide

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;

int gcd(int a,int b)
{
    if(b==0) return a;
    return gcd(b,a%b);
}

int main()
{
    int t,n;
    scanf("%d",&t);
    for(int i=1;i<=t;i++)
    {
        int x1,y1,x2,y2,dx,dy,s,edge;
        scanf("%d",&n);
        x1 = y1 = edge = s = 0;
        for(int j=0;j<n;j++)
        {
            scanf("%d %d",&dx,&dy);
            edge += gcd(abs(dx),abs(dy));
            x2 = x1+dx; y2 = y1+dy;
            s += x1*y2 - x2*y1;
            x1 = x2; y1 = y2;
        }
        s = abs(s);
        printf("Scenario #%d:\n",i);
        printf("%d %d %.1lf\n\n",(s+2-edge)>>1,edge,s/2.0);
    }
    return 0;
}

参考文章:https://blog.csdn.net/qq_33362864/article/details/52298669
svg