九度OJ 1437 To Fill or Not to Fill -- 贪心算法

题目地址:http://ac.jobdu.com/problem.php?pid=1437
php

 

题目描述:

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.this

输入:

For each case, the first line contains 4 positive numbers: Cmax (<= 100), the maximum capacity of the tank; D (<=30000), the distance between Hangzhou and the destination city; Davg (<=20), the average distance per unit gas that the car can run; and N (<= 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: Pi, the unit gas price, and Di (<=D), the distance between this station and Hangzhou, for i=1,...N. All the numbers in a line are separated by a space.spa

输出:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print "The maximum travel distance = X" where X is the maximum possible distance the car can run, accurate up to 2 decimal places.blog

样例输入:
50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300
50 1300 12 2
7.10 0
7.00 600
样例输出:
749.17
The maximum travel distance = 1200.00
/*
 * Main.c
 *
 *  Created on: 2014年1月18日
 *      Author: Shaobo
 *      greedy algorithm
 */
#include <stdio.h>
#include <stdlib.h>
#include <math.h>
 
#define MAXN 501
#define MAXC 30000000.0
 
typedef struct station{
    float price;
    int dist;
}Station;
 
int compare(const void * p, const void * q){
    Station * p1 = (Station *)p;
    Station * q1 = (Station *)q;
    return p1->dist - q1->dist;
}
 
int main(void){
    int Cmax, D, Davg, N;  //容量、距离、每单位气行驶的距离、加气站总数
    int i;
    Station sta[MAXN];
    float sum, remind_gas, tmp;
    int k, step;
 
    while (scanf("%d %d %d %d", &Cmax, &D, &Davg, &N) != EOF){
        for (i=0; i<N; ++i){
            scanf("%f %d", &sta[i].price, &sta[i].dist);
        }
        sta[N].dist = D;
        sta[N].price = 1000000.0;
        qsort(sta, N, sizeof(Station), compare);  //按与杭州距离大小给加气站排序
        if (sta[0].dist > 0){
            printf ("The maximum travel distance = 0.00\n");
            continue;
        }
        sum = 0;             //总费用
        step = Cmax*Davg;    //加满油行驶最大距离
        remind_gas = 0;      //剩余油量
        for (i=0; i<N; ++i){
            k = i+1;
            if (i != 0)
                remind_gas -= ((float)(sta[i].dist -sta[i-1].dist))/Davg;
            for (; k<N && sta[k].price>=sta[i].price; ++k)
                continue;
            if (sta[k].dist-sta[i].dist > step){
                sum += (Cmax-remind_gas)*sta[i].price;
                remind_gas = Cmax;
            }
            else{
                tmp = ((float)(sta[k].dist-sta[i].dist))/Davg - remind_gas;
                if (fabs(tmp)>1e-5 && tmp>0){
                    sum += tmp*sta[i].price;
                    remind_gas = ((float)(sta[k].dist-sta[i].dist))/Davg;
                }
            }
            if (sta[i+1].dist - sta[i].dist > step){
                printf ("The maximum travel distance = %.2f\n", (float)(sta[i].dist+step));
                break;
            }
        }
        if (i == N){
            printf ("%.2f\n", sum);
        }
    }
 
    return 0;
}