PAT 甲级 1050.String Subtraction C++/Java

题目来源java

Given two strings S1 and S2, S=S1−S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1−S2 for any given strings. However, it might not be that simple to do it fast.ios

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.c++

Output Specification:

For each test case, print S1−S2 in one line.spa

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.

题意:

给两个字符串s1,s2,计算s1-s2(在s1中删除掉s2中出现过的字符)code

分析:

  • s2的字符存入哈希map
  • 遍历s1,看是否在map中出现
    • 出现:不输出
    • 没出现:输出

c++实现:

#include <iostream>
#include <unordered_map>
#include <string>

using namespace std;
int main() {
    string s1, s2;
    getline(cin, s1);
    getline(cin, s2);
    unordered_map<char, int> charMap;
    for (int i = 0; i < s2.size(); ++i) {
        charMap[s2[i]] = 1;
    }
    for (int i = 0; i < s1.size(); ++i) {
        if (charMap[s1[i]] != 1) {
            cout << s1[i];
        }
    }
    return 0;
}

Java实现:

相关文章
相关标签/搜索