ACM Red and Black(挑战程序设计竞赛)

Red and Black

Time Limit: 1000ms
Memory Limit: 30000KB
This problem will be judged on  PKU. Original ID:  1979
64-bit integer IO format:  %lld      Java class name:  Main
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

Source

题目大意:有一个覆盖着矩形地板的矩形房间,矩形地板有红色和黑色两种,有一我的刚开始站在一块黑色地板上,他能向四个方向行走,可是,只能走上黑色地板,不能走在红色地板上.
问这我的他能走在上面的黑色地板数目.

解题思路:
深度优先搜索

#include <iostream>
#include <cstring>
#include <cstdio>

using namespace std;

#define MAX_W 21

int w,h;
char map[MAX_W][MAX_W];
int dx[]={1,-1,0,0};
int dy[]={0,0,1,-1};
bool vis[MAX_W][MAX_W];
int cnt;

void dfs(int x,int y)
{
	vis[y][x]=true;
	cnt++;

	for(int i=0;i<4;i++)
	{
		int nx=x+dx[i],ny=y+dy[i];
		if(nx>=0 && nx<w && ny>=0 && ny<h && !vis[ny][nx] && map[ny][nx]!='#')
			dfs(nx,ny);
	}
}

int main()
{
	int sx,sy;

	scanf("%d%d",&w,&h);
	while(w!=0 || h!=0)
	{
		for(int i=0;i<h;i++)
			scanf("%s",map[i]);

		for(int i=0;i<h;i++)
		{
			for(int j=0;j<w;j++)
			{
				if(map[i][j]=='@')
				{
					sx=j;sy=i;
				}
			}
		}
		cnt=0;
		memset(vis,0,sizeof(vis));
		dfs(sx,sy);
		printf("%d\n",cnt);
		scanf("%d%d",&w,&h);
	}

	return 0;
}