PAT-1004 Counting Leaves

1004 Counting Leaves (30 分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.node

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:ios

ID K ID[1] ID[2] ... ID[K]git

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.The input ends with N being 0. That case must NOT be processed.算法

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line. The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.数组

Sample Input:

2 1
01 1 02app

Sample Output:

0 1spa

算法说明:

算法要求求出每一层没有孩子节点的个数并依次输出,本文采用vector存储结点,固然你能够本身定义结构体。而后用递归计算每一层的没有孩子结点的个数,这时就必须有个数组book[depth]来记录啦,下标表明层数,对应的值表示这一层无孩子结点个数。递归中止的条件为 :vector[index].size()==0 说明当前结点没有孩子结点,使book[depth]++,下面贴出代码。

3d

树结构与vector存储

// 1004 Counting Leaves.cpp : Defines the entry point for the console application.
//

#include "stdafx.h"
#include <iostream>
#include <vector>
using namespace std;

vector<int> vec[100];
int maxDepth=-1;
int book[100]={0};
/**
4 2
01 2 02 03
02 1 04

**/
void dfs(int index,int depth){
    if(vec[index].size()==0){
        book[depth]++;
        if(depth>maxDepth)
            maxDepth=depth;
        return;
    }
    for(int i=0;i<vec[index].size();i++)
        dfs(vec[index].at(i),depth+1);
}
int main(int argc, char* argv[])
{
    int N,M,node,k,leaf;
    cin >>N>>M;
    for(int i=0;i<M;i++){
        cin >>node>>k;
        for(int j=0;j<k;j++){
            cin >> leaf;
            vec[node].push_back(leaf);
        }
    }
    dfs(1,0);
    cout<<book[0];
    for(int j=1;j<=maxDepth;j++){
        cout<<" "<<book[j];
    } 
    return 0;
}

2020考研打卡次日,你可知道星辰之变,骄阳岂是终点?千万不要小看一我的的决心。加油!!!

未来的你必定会感谢如今奋斗的本身
相关文章
相关标签/搜索