POJ 3078 - Shuffle'm Up - [模拟题]

题目连接:http://poj.org/problem?id=3087ios

Descriptionexpress

A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips, S1 and S2, each stack containing C chips. Each stack may contain chips of several different colors.ui

The actual shuffle operation is performed by interleaving a chip from S1 with a chip from S2 as shown below for C = 5:this

The single resultant stack, S12, contains 2 * C chips. The bottommost chip of S12 is the bottommost chip from S2. On top of that chip, is the bottommost chip from S1. The interleaving process continues taking the 2nd chip from the bottom of S2 and placing that on S12, followed by the 2nd chip from the bottom of S1 and so on until the topmost chip from S1 is placed on top of S12.spa

After the shuffle operation, S12 is split into 2 new stacks by taking the bottommost C chips from S12 to form a new S1 and the topmost C chips from S12 to form a new S2. The shuffle operation may then be repeated to form a new S12.code

For this problem, you will write a program to determine if a particular resultant stack S12 can be formed by shuffling two stacks some number of times.orm

Inputblog

The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.ip

Each dataset consists of four lines of input. The first line of a dataset specifies an integer C, (1 ≤ C ≤ 100) which is the number of chips in each initial stack (S1 and S2). The second line of each dataset specifies the colors of each of the C chips in stack S1, starting with the bottommost chip. The third line of each dataset specifies the colors of each of the C chips in stack S2 starting with the bottommost chip. Colors are expressed as a single uppercase letter (A through H). There are no blanks or separators between the chip colors. The fourth line of each dataset contains 2 * C uppercase letters (A through H), representing the colors of the desired result of the shuffling of S1 and S2 zero or more times. The bottommost chip’s color is specified first.ci

Output

Output for each dataset consists of a single line that displays the dataset number (1 though N), a space, and an integer value which is the minimum number of shuffle operations required to get the desired resultant stack. If the desired result can not be reached using the input for the dataset, display the value negative 1 (−1) for the number of shuffle operations.

Sample Input

2
4
AHAH
HAHA
HHAAAAHH
3
CDE
CDE
EEDDCC

Sample Output

1 2
2 -1

 

题意:

给出两堆一样数量的筹码 $S_1$ 和 $S_2$。洗筹码的方式是,将 $S_1$ 和 $S_2$ 互相间隔插入,同时 $S_1$ 靠上,$S_2$ 靠下。

而后将新生成的筹码堆的下面一半做为新的 $S_1$,上面一半做为新的 $S_2$。不断循环如上操做,问是否能达到题目所给的目标结果。

 

题解:

这个在kuangbin的专题里放进了搜索里面,然而感受每次洗筹码生成的结果都是惟一的,因此不就是一直洗牌直到能达到目标为止吗?感受并非搜索啊……

洗牌若是洗了一个循环,发现并不能达到目标的话,就是Impossible了。

 

AC代码:

#include<cstdio>
#include<iostream>
#include<string>
using namespace std;
typedef pair<string,string> pss;

int n;
pss st,ed;
void nxt(pss &x)
{
    string s;
    for(int i=0;i<n;i++) s+=x.second[i], s+=x.first[i];
    x.first=s.substr(0,n);
    x.second=s.substr(n,n);
}
int main()
{
    int T;
    cin>>T;
    for(int kase=1;kase<=T;kase++)
    {
        scanf("%d",&n);
        cin>>st.first>>st.second;
        cin>>ed.first;
        ed.second=ed.first.substr(n,n);
        ed.first.erase(n,n);
        int cnt;
        pss now;
        for(cnt=0,now=st;;cnt++,nxt(now))
        {
            if(now==st && cnt>0)
            {
                printf("%d -1\n",kase);
                break;
            }
            if(now==ed)
            {
                printf("%d %d\n",kase,cnt);
                break;
            }
        }
    }
}
相关文章
相关标签/搜索