PAT-1007 Maximum Subsequence Sum

1007 Maximum Subsequence Sum (25 分)

Given a sequence of K integers { N11, N2, ..., NK}. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj} where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.ios

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.算法

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.app

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21spa

Sample Output:

10 1 4code

算法说明:

算法大致意识是求得序列最大和,这个最大和序列从i开始到j结束是顺序的,若序列全为负和为零,最后输出和,位置i,j对应的值。思路:两层循环,记录最大和ci

// 1007 Maximum Subsequence Sum.cpp : Defines the entry point for the console application.
//

#include "stdafx.h"
#include <iostream>
using namespace std;

int K;
int num[1000]={0};

bool isZero(){
    for(int i=0;i<K;i++)
        if(num[i]>=0)
            return false;
    return true;
}
int main(int argc, char* argv[])
{
    cin >>K;
    int start=0,end=K-1,sum=0;
    int i,j;
    for(int x=0;x<K;x++)
        cin >>num[x];
    if(isZero())
        cout << sum << " " << num[start] << " " << num[end]<<endl;
    else{
        sum=num[0];
        int temp;
        for(i=0;i<K;i++){
            temp=0;
            for(j=i;j<K;j++){
                temp+=num[j];
                if(temp>sum){
                    sum=temp;
                    start=i;
                    end=j;
                }
            }
        }
        cout << sum << " " << num[start] << " " << num[end]<<endl;
    }
    return 0;
}

2020考研打卡第九天,你可知道星辰之变,骄阳岂是终点?千万不要小看一我的的决心。加油!!!

汝等给我看好了,致那些瞧不起咱们的人
相关文章
相关标签/搜索