POJ 2503 Babelfish (STL)

题目连接ios

Descriptionc++

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.app

Inputoop

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.spa

Outputcode

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".ip

Sample Inputci

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslayget

atcay
ittenkay
oopslayinput

Sample Output

cat
eh
loops

分析:
给定一些单词以及每一个单词对应的意思,这之间是一一对应的。而后询问某一个单词对应的意思是什么,若是有对应的意思的话,就把对应的意思输出来,不然输出“eh”。

代码:

#include <iostream>
#include <string>
#include <map>
#include<stdio.h>
using namespace std;
map <string,string>mp;
int main ()
{
    char ch[30],str1[15],str2[15];
    while (gets(ch))
    {
        if (ch[0]==0)
            break;
        sscanf(ch,"%s%s",str1,str2);
        mp[str2]=str1;
    }
    while (gets(ch))
    {
        map<string,string>::iterator it;
        it=mp.find(ch);
        if (it!=mp.end())
            cout<<(*it).second<<endl;
        else
            printf("eh\n");
    }
    return 0;
}
相关文章
相关标签/搜索