区间重叠问题 (贪心)

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations


Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
Sample Output
Case 1: 2
Case 2: 1

大意: 海岸线的上方是islands,海岸线上有雷达,给出islands坐标,可以把全部岛检测到并且须要最少数量的雷达,求这个最小数量。
解题思路:①给的points(islands)是肯定的,而雷达是不肯定的,咱们能够以每个islands为圆心以输入r为半径作圆,由于雷达在海岸线上(x轴),若是这个圆与x轴相交,设交点为x1,x2(由圆的公式或者勾股定理加已知条件,能够求出两点坐标),那么在这一段x1-x2中,必然存在一个雷达能够检测到这个岛(距离小于半径),那么,咱们此时作第二个点的圆(假设咱们的点已经排好序,按x的大小,若是x相等,把y小的放在前面,也能够不考虑y,本身分析),假设也会与x轴相交(若是不相交,确定输出-1,由于没有雷达会检测到,不存在这样的雷达),设交点为x3,x4,若是区间x1—x2与区间x3—x4相交,那么存在一个雷达会同时检测到这两个点,若是不相交,那么就会须要两个雷达,依次类推,但须要注意一点,有可能第二个点的x4<第一个点的x2,这样第二个区间被第一个区间彻底包含,这样咱们在判断时会产生一个区间范围缩小的问题(具体看代码实现)。
②以雷达为考虑中心,把小岛考虑在某个雷达监测的最边上,这样岛左边与右边各有一个极限雷达,两个雷达之间必然存在一个雷达,包括两个极限雷达能够检测到这个岛的存在,也是区间问题,做为一种参考思路,不作详述。


一下是第一种方法的AC代码,仅供参考,新手,不免代码有缀(一开始本身有思路,可是没考虑区间包含,参考了其余博主代码,作了代码优化)。
#include <iostream>
#include<math.h>
#include <algorithm>
using namespace std;
typedef struct points{
double x;
double y;}type; bool cmp(type a,type b) {
   if (a.x==b.x)
   return a.y<b.y;
   return a.x<b.x;
}
int main(){
type *pt,*xd;
double x1,x2,border;
int i,j,k,n,count= 1,r,flag= 1,flag1= 0;
while ( scanf( "%d%d",&n,&r))
{
if (n== 0&&r== 0)
break;
pt= new type[n];
xd= new type[n];
for (i= 0;i<n;i++)
{
cin>>pt[i].x>>pt[i].y;
  if (pt[i].y>r||r< 0||pt[i].y< 0)
flag1= 1;
    }
    if (flag1)
{
     cout<< "Case"<< " "<<flag<< ":"<< " "<< "-1"<< endl;
flag1= 0;
flag++;
}
    else
    {
sort (pt,pt+n,cmp);
for (i= 0;i<n;i++)
{
xd[i].x=pt[i].x- sqrt(r*r-pt[i].y*pt[i].y);
xd[i].y=pt[i].x+ sqrt(r*r-pt[i].y*pt[i].y); }border=xd[ 0].y;
    for (i= 1;i<n;i++)
    {
      if (border>xd[i].y)
       border=xd[i].y;
       else
       {
       if (xd[i].x>border)
       {
border=xd[i].y;
       count++;
         }
   }
}
cout<< "Case"<< " "<<flag<< ":"<< " "<<count<< endl;
count= 1;
flag++;
    }
}
return 0; }