PAT (Advanced Level) Practice 1092 To Buy or Not to Buy (map应用于字符串字符个数的统计)

 

PAT (Advanced Level) Practice  1092 To Buy or Not to Buy (20 分)ios

Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must check whether a string in the shop contains all the beads she needs. She now comes to you for help: if the answer is Yes, please tell her the number of extra beads she has to buy; or if the answer is No, please tell her the number of beads missing from the string.less

For the sake of simplicity, let's use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors. For example, the 3rd string in Figure 1 is the one that Eva would like to make. Then the 1st string is okay since it contains all the necessary beads with 8 extra ones; yet the 2nd one is not since there is no black bead and one less red bead.spa

figbuy.jpg

Figure 1code

Input Specification:

Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.blog

Output Specification:

For each test case, print your answer in one line. If the answer is Yes, then also output the number of extra beads Eva has to buy; or if the answer is No, then also output the number of beads missing from the string. There must be exactly 1 space between the answer and the number.ci

Sample Input 1:

ppRYYGrrYBR2258
YrR8RrY

Sample Output 1:

Yes 8

Sample Input 2:

ppRYYGrrYB225
YrR8RrY

Sample Output 2:

No 2

 借鉴:https://www.jianshu.com/字符串

#include <iostream>
#include <cstdio>
#include <map>
#include <string>
#include <algorithm>
using namespace std;
//map应用于字符串的字符的统计。
int main()
{
    int i;
    map<char,int> m1,m2;
    string s1,s2;
    cin>>s1>>s2;
    for(i=0;i<s1.length();i++) m1[s1[i]]++;  //m1是给的手链
    for(i=0;i<s2.length();i++) m2[s2[i]]++;  //m2是想要的手链
    int diff=0;
    for(map<char,int>::iterator it=m2.begin();it!=m2.end();it++) //以本身想要的链去枚举比较。
    if(m2[it->first]>m1[it->first]) diff+=m2[it->first]-m1[it->first];
    if(diff==0)  cout<<"Yes "<<(int)(s1.length()-s2.length());
    else cout<<"No "<<diff;
    return 0;
}

p/37bf8e619d60get