hdu 1541 Stars

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.
 


 

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
 


 

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 


 

Sample Input
5 1 1 5 1 7 1 3 3 5 5
 


 

Sample Output
1 2 1 1 0

 

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#define N 15003
#define M 32003
int c[M],hash[N];
int lb(int x)  //基本的树状数组模板呀
{
    return x&(-x);
}
void updata(int i)
{
  for(;i<=M;i+=lb(i))
     c[i]+=1;
}
int rs(int k)
{
    int sum=0;
    for(;k>0;k-=lb(k))
      sum+=c[k];
    return sum;
}
int main()
{  //freopen("in.txt","r",stdin);
  int i,x,y,n;
  while(scanf("%d",&n)!=EOF)
  {
     memset(c,0,sizeof(c));
     memset(hash,0,sizeof(hash));
      for(i=0;i<n;i++)
       {
           scanf("%d%d",&x,&y);
           x++;     //开始时这个忘记勒,出现了X=0;树状数组这个必需要注意!!!悲剧!
           hash[rs(x)]++;
           updata(x);数组

       }
       for(i=0;i<n;i++)
         printf("%d\n",hash[i]);
  }
  return 0;
}
                                                                           -----江财小子ide