HDU6029 Happy Necklace 2017-05-07 19:11 45人阅读 评论(0) 收藏

Happy Necklace

                                                                          Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
                                                                                                          Total Submission(s): 19    Accepted Submission(s): 9


Problem Description
Little Q wants to buy a necklace for his girlfriend. Necklaces are single strings composed of multiple red and blue beads.
Little Q desperately wants to impress his girlfriend, he knows that she will like the necklace only if for every prime length continuous subsequence in the necklace, the number of red beads is not less than the number of blue beads.
Now Little Q wants to buy a necklace with exactly  n  beads. He wants to know the number of different necklaces that can make his girlfriend happy. Please write a program to help Little Q. Since the answer may be very large, please print the answer modulo  109+7 .
Note: The necklace is a single string,  {not a circle}.

Input
The first line of the input contains an integer  T(1T10000) , denoting the number of test cases.
For each test case, there is a single line containing an integer  n(2n1018) , denoting the number of beads on the necklace.

Output
For each test case, print a single line containing a single integer, denoting the answer modulo  109+7 .

Sample Input
  
  
  
  
2 2 3
 
Sample Output
  
  
  
  
3 4
 

Source
 
———————————————————————————————————————————————

题意:一个项链有n个珠子,这个项链是个链,不是一个环,项链上连续素数个珠子中红色珠子个数要大于等于蓝色珠子php

解题思路:找出前面几个,发现存在递推关系f[i]=f[i-1]+f[i-3],而后构造矩阵,矩阵快速幂ios


                                                                                   {1 1 0}app

     矩阵构造: {a[i],a[i-1],a[i-2]}={a[i-1],a[i-2],a[i-3]}*{0 0 1}less

                                                                                   {1 0 0}atom


#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <cmath>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

#define LL long long
const int INF=0x3f3f3f3f;
#define mod 1000000007

LL n;

struct Matrix
{
    LL v[5][5];
    Matrix()
    {
        memset(v,0,sizeof v);
    }
}dan;

Matrix mul(Matrix a,Matrix b,int d)
{
    Matrix ans;
    for(int i=1; i<=d; i++)
    {
        for(int j=1; j<=d; j++)
        {
            for(int k=1; k<=d; k++)
            {
                ans.v[i][j]+=a.v[i][k]*b.v[k][j];
                ans.v[i][j]%=mod;
            }
        }
    }
    return ans;
}

Matrix pow(Matrix a,LL k,int d)
{
    Matrix ans=dan;
    while(k)
    {
        if(k&1) ans=mul(ans,a,d);
        k>>=1;
        a=mul(a,a,d);
    }
    return ans;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lld",&n);
        if(n==2) {printf("3\n");continue;}
        if(n==3) {printf("4\n");continue;}
        if(n==4) {printf("6\n");continue;}
        Matrix ans,a;
        a.v[1][1]=a.v[3][1]=a.v[1][2]=a.v[2][3]=1;
        dan.v[1][1]=6,dan.v[1][2]=4,dan.v[1][3]=3;
        ans=pow(a,n-4,3);
        printf("%lld\n",ans.v[1][1]);
    }
    return 0;
}
相关文章
相关标签/搜索