数据结构实验之链表五:单链表的拆分

数据结构实验之链表五:单链表的拆分

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

输入N个整数顺序创建一个单链表,将该单链表拆分红两个子链表,第一个子链表存放了全部的偶数,第二个子链表存放了全部的奇数。两个子链表中数据的相对次序与原链表一致。

输入

第一行输入整数N;;
第二行依次输入N个整数。

输出

第一行分别输出偶数链表与奇数链表的元素个数;
第二行依次输出偶数子链表的全部数据;
第三行依次输出奇数子链表的全部数据。

示例输入

10
1 3 22 8 15 999 9 44 6 1001

示例输出

4 6
22 8 44 6 
1 3 15 999 9 1001

提示

不得使用数组!

来源

 

示例程序

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
using namespace std;
struct node
{
    int data;
    struct node *next;
};
struct node *creat(int n)
{
    int i;
    struct node *head,*p;
    head=(struct node *)malloc(sizeof(struct node));
    head->next=NULL;
    for(i=0;i<n;i++)
    {
        p=(struct node *)malloc(sizeof(struct node));
        scanf("%d",&p->data);
        p->next=head->next;
        head->next=p;
    }
    return head;
};
struct node *spilt(struct node *head)
{
    struct node *head1 ,*p,*q;
    int a=0,b=0;
    head1=(struct node *)malloc(sizeof(struct node));
    head1->next=NULL;
    p=head->next;
    head->next=NULL;
    q=p->next;
    while(p!=NULL)
    {
        if(p->data%2==0)
        {
            p->next=head->next;
            head->next=p;
            a++;
        }
        else
        {
            p->next=head1->next;
            head1->next=p;
            b++;
        }
        p=q;
        if(q!=NULL)
            q=q->next;
    }
    cout<<a<<' '<<b<<endl;
    return head1;
};
int main()
{
    int n;
    struct node *head,*p,*q,*head1;
    scanf("%d",&n);
    head=creat(n);
    head1=spilt(head);
    p=head->next;
    while(p!=NULL)
    {
        if(p->next!=NULL)
            printf("%d ",p->data);
        else
            printf("%d\n",p->data);
        p=p->next;
    }
    q=head1->next;
    while(q!=NULL)
    {
        if(q->next!=NULL)
            printf("%d ",q->data);
        else
            printf("%d\n",q->data);
        q=q->next;
    }
    return 0;
}